Mobile App - Samsung 14/15

Incident Report for SIPcity

Update

We are continuing to monitor for any further issues.
Posted Jul 24, 2025 - 17:07 AEST

Monitoring

Service Status — Android 14 One-Way Audio Issue (Samsung Devices)

Issue Resolved
We have identified and fixed the issue that caused one-way audio on outbound calls for customers using our Samsung Android app on Android 14 and later. The root cause was an Android OS conflict affecting audio permissions and background processes, not a defect in the app itself.

Roll-Out Schedule
• Play Store update: In Google’s standard review queue and expected to go live within 48 hours.
• Recommendation: Most users can simply wait for the automatic Play Store update.



Need the Fix Right Away?

You can sideload the patched APK immediately:
1. Download the APK from our secure Google Drive link:
https://drive.google.com/file/d/1rNLlQ6yE1mXaaHdhnjVFGFuEpDSZk9d3/view?usp=sharing
2. On your Android device, locate the file (either in the notification shade or the Files app) and tap it.
3. When prompted, allow your browser or file manager to install from unknown sources.
4. Follow the on-screen instructions to complete installation.
Posted Jul 24, 2025 - 17:07 AEST

Update

We are continuing to work on a fix for this issue.
Posted Jul 07, 2025 - 10:22 AEST

Identified

Overview

We are currently investigating an issue affecting audio functionality on VoIP calls made using the 2talk and SIPcity Android mobile apps on certain Samsung devices running Android 14 and 15.



📱 Affected Devices
• Samsung Galaxy A16 (Android 14)
• Samsung Galaxy A73 (Android 15)
• Other Samsung devices running Android 14 or 15 may also be impacted.



🛠️ Identified Issue

On these devices:
• Calls connect, but neither party can hear audio.
• The issue appears to be caused by changes in microphone permissions and audio handling introduced in Samsung’s Android 14/15 software.

✅ This issue does not affect:
• iPhone (iOS) devices
• Google Pixel or other non-Samsung Android devices
• Samsung devices running Android 13 or earlier



🔍 What We’ve Found So Far
• Samsung Android 14/15 devices may deny microphone access at runtime, even when permissions are granted.
• As a result, VoIP media streams fail to initialize, leading to one-way or no-way audio.
• This issue appears specific to Samsung’s system configuration and is not related to push notifications or account registration.



👷‍♂️ What We’re Doing
• We’re implementing a Samsung-specific fix to work around these permission and routing issues.
• A patch update is being tested that forces microphone access and adjusts the way audio streams are initiated on Samsung Android 14/15.
• We are also reaching out to Samsung for support.



Temporary Workarounds

If you are affected:
1. Bluetooth or external appear to resolve the the mic issue on most Android



📅 ETA for Resolution

We expect to deploy an app update with a Samsung compatibility patch within the next 5–7 days.
Posted Jul 07, 2025 - 10:16 AEST
This incident affects: MySIPcity app.