Android Google Pixel - Push Notifications

Incident Report for SIPcity

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 10:34 AEDT

Identified

Status: Identified
Impact: Mobile Apps – Android (Google Pixel devices only)
Platforms unaffected: Samsung, Oppo, Motorola, Apple iOS

Summary

We’ve identified an issue introduced in a recent Android app update that unexpectedly disabled the “Allow SIP Client” functionality on Google Pixel devices (Android /14/15) breaking Push Notifications, responsible for waking closed apps on Pixel phones. Outbound calling is not impacted.

Important:
Samsung and other Android manufacturers are not affected.

Current Behaviour
• Pixel phones: SIP client cannot register (toggle appears disabled or non-functional).
• Samsung & other Android: operating normally.
• iOS: unaffected.

Cause

A recent permissions and compatibility change in the Android build has impacted how Pixel devices handle the SIP/VoIP stack and system-level calling account permissions.

Actions Underway
• A patch build is already in progress to re-enable SIP functionality on Pixel devices.
• QA testing is underway on Pixel 7, Pixel 8, and Pixel Fold models.
• Release ETA will be posted in the next update.

Workaround

At this time, no reliable workaround exists on impacted Pixel devices due to the OS-level enforcement of the permission.
Calls and messaging continue to operate normally on iOS and Samsung devices.

Subject to Google's internal approval time frame, we anticipate new PlayStore update within the next 48 hours.
Posted Dec 01, 2025 - 11:53 AEDT
This incident affected: MySIPcity app.