Outbound Calling
Incident Report for SIPcity
Resolved
This incident is now resolved.
Posted Jul 17, 2019 - 10:11 AEST
Investigating
We are currently investigating an outbound calling issues.
We will provide an update once we know more.
Posted Jul 17, 2019 - 10:03 AEST
This incident affected: SIPcity Calling Platform (Network).