Account balances incorrect: Billing Anniversary 12th of month
Incident Report for SIPcity
Resolved
This has been resolved and all invoices have been regenerated.
Will will monitor over the next few days.
Posted May 09, 2019 - 18:28 AEST
Investigating
Customers with a bill anniversary of 12th of the month may see incorrect account balances as these have been carried forward from April into this month. Our billing team is working on this resolving this now.
Posted May 07, 2019 - 15:51 AEST
This incident affected: SIPcity Cloud PBX.