Service Disruption to CloudPBX
Incident Report for SIPcity
Resolved
This incident has been resolved.
Posted Sep 26, 2017 - 14:14 AEST
Identified
YourCloudPBX is currently unavailable, our team has identified the issue and a resolution is underway.
Posted Sep 26, 2017 - 14:09 AEST