Account access
Incident Report for SIPcity
Resolved
This incident has been resolved.
Posted Jul 16, 2019 - 21:22 AEST
Investigating
SIPcity accounts are currently unavailable, we expect this to be unavailable for the next 45mins. We will provide an update once the site is available again.
Please note this will have no effect on customers calling.
Posted Jul 16, 2019 - 20:32 AEST
This incident affected: SIPcity Cloud PBX.